<!DOCTYPE html>
<html lang="">

<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="X-UA-Compatible" content="ie=edge">
<meta itemprop="name" content="Advanced gRPC Error Usage">
<meta itemprop="description" content="How to best handle errors in Go is a divisive issue, leading to opinion pieces by illustrious bloggers such as Dave Cheney, the commander himself Rob Pike as well as the official Go blog. I&rsquo;m not going to tackle those opinions here, instead I&rsquo;m going to talk about best practices for errors when using gRPC and Go.
The gRPC Status package The Go gRPC implementation has a status package which exposes a nice simple interface for creating rich gRPC errors."><meta itemprop="datePublished" content="2018-03-19T00:00:00&#43;00:00" />
<meta itemprop="dateModified" content="2018-03-19T00:00:00&#43;00:00" />
<meta itemprop="wordCount" content="889">
<meta itemprop="keywords" content="go,gRPC," /><meta property="og:title" content="Advanced gRPC Error Usage" />
<meta property="og:description" content="How to best handle errors in Go is a divisive issue, leading to opinion pieces by illustrious bloggers such as Dave Cheney, the commander himself Rob Pike as well as the official Go blog. I&rsquo;m not going to tackle those opinions here, instead I&rsquo;m going to talk about best practices for errors when using gRPC and Go.
The gRPC Status package The Go gRPC implementation has a status package which exposes a nice simple interface for creating rich gRPC errors." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://jbrandhorst.com/post/grpc-errors/" /><meta property="article:section" content="post" />
<meta property="article:published_time" content="2018-03-19T00:00:00&#43;00:00" />
<meta property="article:modified_time" content="2018-03-19T00:00:00&#43;00:00" />

<meta name="twitter:card" content="summary"/>
<meta name="twitter:title" content="Advanced gRPC Error Usage"/>
<meta name="twitter:description" content="How to best handle errors in Go is a divisive issue, leading to opinion pieces by illustrious bloggers such as Dave Cheney, the commander himself Rob Pike as well as the official Go blog. I&rsquo;m not going to tackle those opinions here, instead I&rsquo;m going to talk about best practices for errors when using gRPC and Go.
The gRPC Status package The Go gRPC implementation has a status package which exposes a nice simple interface for creating rich gRPC errors."/>

	<link rel="apple-touch-icon" sizes="180x180" href="https://jbrandhorst.com/apple-touch-icon.png">
	<link rel="icon" type="image/png" sizes="32x32" href="https://jbrandhorst.com/favicon-32x32.png">
	<link rel="icon" type="image/png" sizes="16x16" href="https://jbrandhorst.com/favicon-16x16.png">
	<link rel="manifest" href="https://jbrandhorst.com/site.webmanifest">
	<link rel="mask-icon" href="https://jbrandhorst.com/safari-pinned-tab.svg" color="">
	<link rel="shortcut icon" href="https://jbrandhorst.com/favicon.ico">

	<title>Advanced gRPC Error Usage</title>
	<link rel="stylesheet" href="https://jbrandhorst.com/css/style.min.037b6ee8f8c1baab6a3d0a9da11c3ff18a7552471f16c59fd98538d5ce99208b.css" integrity="sha256-A3tu6PjBuqtqPQqdoRw/8Yp1UkcfFsWf2YU41c6ZIIs=" crossorigin="anonymous">
	
	<link rel="stylesheet" href="https://jbrandhorst.com/css/main.css">
</head>

<body id="page">
	
	<header id="site-header" class="animated slideInUp">
		<div class="hdr-wrapper section-inner">
			<div class="hdr-left">
				<div class="site-branding">
					<a href="https://jbrandhorst.com">Go Ahead</a>
				</div>
				<nav class="site-nav hide-in-mobile">
					
				<a href="https://jbrandhorst.com/post/">Blog</a>
				<a href="https://jbrandhorst.com/page/about/">About</a>
				<a href="https://jbrandhorst.com/page/presentations/">Presentations</a>

				</nav>
			</div>
			<div class="hdr-right hdr-icons">
				<span class="hdr-social hide-in-mobile"><a href="https://twitter.com/JohanBrandhorst" target="_blank" rel="noopener me" title="Twitter"><svg xmlns="http://www.w3.org/2000/svg" class="feather" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M23 3a10.9 10.9 0 0 1-3.14 1.53 4.48 4.48 0 0 0-7.86 3v1A10.66 10.66 0 0 1 3 4s-4 9 5 13a11.64 11.64 0 0 1-7 2c9 5 20 0 20-11.5a4.5 4.5 0 0 0-.08-.83A7.72 7.72 0 0 0 23 3z"></path></svg></a><a href="https://github.com/johanbrandhorst" target="_blank" rel="noopener me" title="Github"><svg xmlns="http://www.w3.org/2000/svg" class="feather" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M9 19c-5 1.5-5-2.5-7-3m14 6v-3.87a3.37 3.37 0 0 0-.94-2.61c3.14-.35 6.44-1.54 6.44-7A5.44 5.44 0 0 0 20 4.77 5.07 5.07 0 0 0 19.91 1S18.73.65 16 2.48a13.38 13.38 0 0 0-7 0C6.27.65 5.09 1 5.09 1A5.07 5.07 0 0 0 5 4.77a5.44 5.44 0 0 0-1.5 3.78c0 5.42 3.3 6.61 6.44 7A3.37 3.37 0 0 0 9 18.13V22"></path></svg></a><a href="https://www.linkedin.com/in/jbrandhorst/" target="_blank" rel="noopener me" title="Linkedin"><svg xmlns="http://www.w3.org/2000/svg" class="feather" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M16 8a6 6 0 0 1 6 6v7h-4v-7a2 2 0 0 0-2-2 2 2 0 0 0-2 2v7h-4v-7a6 6 0 0 1 6-6z"></path><rect x="2" y="9" width="4" height="12"></rect><circle cx="4" cy="4" r="2"></circle></svg></a></span><button id="menu-btn" class="hdr-btn" title="Menu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" class="feather feather-menu"><line x1="3" y1="12" x2="21" y2="12"></line><line x1="3" y1="6" x2="21" y2="6"></line><line x1="3" y1="18" x2="21" y2="18"></line></svg></button>
			</div>
		</div>
	</header>
	<div id="mobile-menu" class="animated fast">
		<ul>
			<li><a href="https://jbrandhorst.com/post/">Blog</a></li>
			<li><a href="https://jbrandhorst.com/page/about/">About</a></li>
			<li><a href="https://jbrandhorst.com/page/presentations/">Presentations</a></li>
		</ul>
	</div>


	<main class="site-main section-inner thin animated fadeIn faster">
		<h1>Advanced gRPC Error Usage</h1>
		<div class="content">
			<p>How to best handle errors in Go is a divisive issue, leading
to opinion pieces by illustrious bloggers such as
<a href="https://dave.cheney.net/tag/error-handling">Dave Cheney</a>,
the commander himself
<a href="https://commandcenter.blogspot.co.uk/2017/12/error-handling-in-upspin.html">Rob Pike</a>
as well as the
<a href="https://blog.golang.org/errors-are-values">official Go blog</a>. I&rsquo;m
not going to tackle those opinions here, instead I&rsquo;m going to talk
about best practices for errors when using gRPC and Go.</p>
<h3 id="the-grpc-status-package">The gRPC Status package<a href="#the-grpc-status-package" class="anchor" aria-hidden="true"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M15 7h3a5 5 0 0 1 5 5 5 5 0 0 1-5 5h-3m-6 0H6a5 5 0 0 1-5-5 5 5 0 0 1 5-5h3"></path><line x1="8" y1="12" x2="16" y2="12"></line></svg></a></h3>
<p>The Go gRPC implementation has a
<a href="https://godoc.org/google.golang.org/grpc/status"><code>status</code> package</a>
which exposes a nice simple interface for creating rich gRPC errors.</p>
<p>For example, lets say you have a method that takes an ID as a parameter,
but the requested ID did not exist in your store. You could just return
the error your store backend returned, but a good gRPC server should
make use of the gRPC error codes. In this case, <code>codes.NotFound</code> is
the appropriate code.</p>
<div class="highlight"><pre class="chroma"><code class="language-go" data-lang="go"><span class="nx">err</span> <span class="o">:=</span> <span class="nx">status</span><span class="p">.</span><span class="nf">Error</span><span class="p">(</span><span class="nx">codes</span><span class="p">.</span><span class="nx">NotFound</span><span class="p">,</span> <span class="s">&#34;id was not found&#34;</span><span class="p">)</span>
<span class="k">return</span> <span class="kc">nil</span><span class="p">,</span> <span class="nx">err</span>
</code></pre></div><p>To find which code you should be returning when, make sure to read
<a href="https://godoc.org/google.golang.org/grpc/codes">the extensive documentation for the grpc/codes package</a>.
These errors translate the code and message to the <code>grpc-message</code>
and <code>grpc-status</code> trailers respectively in the
<a href="https://github.com/grpc/grpc/blob/master/doc/PROTOCOL-HTTP2.md#responses">gRPC HTTP2 protocol spec</a>.</p>
<p>Extracting the message and code in a gRPC client is also done through the
<code>status</code> package, with the <a href="https://godoc.org/google.golang.org/grpc/status#FromError"><code>Status.FromError</code></a>.</p>
<div class="highlight"><pre class="chroma"><code class="language-go" data-lang="go"><span class="nx">st</span><span class="p">,</span> <span class="nx">ok</span> <span class="o">:=</span> <span class="nx">status</span><span class="p">.</span><span class="nf">FromError</span><span class="p">(</span><span class="nx">err</span><span class="p">)</span>
<span class="k">if</span> <span class="p">!</span><span class="nx">ok</span> <span class="p">{</span>
    <span class="c1">// Error was not a status error
</span><span class="c1"></span><span class="p">}</span>
<span class="c1">// Use st.Message() and st.Code()
</span></code></pre></div><p>The Go gRPC implementation <a href="https://github.com/grpc/grpc-go/pull/1782">guarantees</a>
that all errors returned from RPC calls are <code>status</code> type errors. Because of this,
you can usually use the
<a href="https://godoc.org/google.golang.org/grpc/status#Convert"><code>status.Convert</code></a> method instead.</p>
<h3 id="advanced-usage">Advanced usage<a href="#advanced-usage" class="anchor" aria-hidden="true"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M15 7h3a5 5 0 0 1 5 5 5 5 0 0 1-5 5h-3m-6 0H6a5 5 0 0 1-5-5 5 5 0 0 1 5-5h3"></path><line x1="8" y1="12" x2="16" y2="12"></line></svg></a></h3>
<p>The <code>status</code> package also comes with the power to attach <em>arbitrary</em>
protobuf metadata to your errors, courtesy of the protobuf <code>Any</code> message type
and the <a href="https://godoc.org/google.golang.org/grpc/status#Status.WithDetails"><code>Status.WithDetails</code></a>
method.</p>
<p>For example, if a request is provided with a parameter that is incorrect regardless
of the state of the system, you may want to return more information about which
field caused the error and why. You could stuff all of this into the error message,
but it is not meant for long messages. Here&rsquo;s an example of using the
<a href="https://godoc.org/google.golang.org/genproto/googleapis/rpc/errdetails"><code>errdetails</code> package</a>
to attach extra error metadata to an error:</p>
<div class="highlight"><pre class="chroma"><code class="language-go" data-lang="go"><span class="nx">st</span> <span class="o">:=</span> <span class="nx">status</span><span class="p">.</span><span class="nf">New</span><span class="p">(</span><span class="nx">codes</span><span class="p">.</span><span class="nx">InvalidArgument</span><span class="p">,</span> <span class="s">&#34;invalid username&#34;</span><span class="p">)</span>
<span class="nx">desc</span> <span class="o">:=</span> <span class="s">&#34;The username must only contain alphanumeric characters&#34;</span>
<span class="nx">v</span> <span class="o">:=</span> <span class="o">&amp;</span><span class="nx">errdetails</span><span class="p">.</span><span class="nx">BadRequest_FieldViolation</span><span class="p">{</span>
    <span class="nx">Field</span><span class="p">:</span> <span class="s">&#34;username&#34;</span><span class="p">,</span>
    <span class="nx">Description</span><span class="p">:</span> <span class="nx">desc</span><span class="p">,</span>
<span class="p">}</span>
<span class="nx">br</span> <span class="o">:=</span> <span class="o">&amp;</span><span class="nx">errdetails</span><span class="p">.</span><span class="nx">BadRequest</span><span class="p">{}</span>
<span class="nx">br</span><span class="p">.</span><span class="nx">FieldViolations</span> <span class="p">=</span> <span class="nb">append</span><span class="p">(</span><span class="nx">br</span><span class="p">.</span><span class="nx">FieldViolations</span><span class="p">,</span> <span class="nx">v</span><span class="p">)</span>
<span class="nx">st</span><span class="p">,</span> <span class="nx">err</span> <span class="o">:=</span> <span class="nx">st</span><span class="p">.</span><span class="nf">WithDetails</span><span class="p">(</span><span class="nx">br</span><span class="p">)</span>
<span class="k">if</span> <span class="nx">err</span> <span class="o">!=</span> <span class="kc">nil</span> <span class="p">{</span>
    <span class="c1">// If this errored, it will always error
</span><span class="c1"></span>    <span class="c1">// here, so better panic so we can figure
</span><span class="c1"></span>    <span class="c1">// out why than have this silently passing.
</span><span class="c1"></span>    <span class="nb">panic</span><span class="p">(</span><span class="nx">fmt</span><span class="p">.</span><span class="nf">Sprintf</span><span class="p">(</span><span class="s">&#34;Unexpected error attaching metadata: %v&#34;</span><span class="p">,</span> <span class="nx">err</span><span class="p">))</span>
<span class="p">}</span>
<span class="k">return</span> <span class="nx">st</span><span class="p">.</span><span class="nf">Err</span><span class="p">()</span>
</code></pre></div><p>In order to extract these errors on the other side, for printing a nicely
formatted error message to the user for example, you can use the
<a href="https://godoc.org/google.golang.org/grpc/status#Status.Details"><code>status.Details</code></a> method:</p>
<div class="highlight"><pre class="chroma"><code class="language-go" data-lang="go"><span class="nx">st</span> <span class="o">:=</span> <span class="nx">status</span><span class="p">.</span><span class="nf">Convert</span><span class="p">(</span><span class="nx">err</span><span class="p">)</span>
<span class="k">for</span> <span class="nx">_</span><span class="p">,</span> <span class="nx">detail</span> <span class="o">:=</span> <span class="k">range</span> <span class="nx">st</span><span class="p">.</span><span class="nf">Details</span><span class="p">()</span> <span class="p">{</span>
    <span class="k">switch</span> <span class="nx">t</span> <span class="o">:=</span> <span class="nx">detail</span><span class="p">.(</span><span class="kd">type</span><span class="p">)</span> <span class="p">{</span>
    <span class="k">case</span> <span class="o">*</span><span class="nx">errdetails</span><span class="p">.</span><span class="nx">BadRequest</span><span class="p">:</span>
        <span class="nx">fmt</span><span class="p">.</span><span class="nf">Println</span><span class="p">(</span><span class="s">&#34;Oops! Your request was rejected by the server.&#34;</span><span class="p">)</span>
        <span class="k">for</span> <span class="nx">_</span><span class="p">,</span> <span class="nx">violation</span> <span class="o">:=</span> <span class="k">range</span> <span class="nx">t</span><span class="p">.</span><span class="nf">GetFieldViolations</span><span class="p">()</span> <span class="p">{</span>
            <span class="nx">fmt</span><span class="p">.</span><span class="nf">Printf</span><span class="p">(</span><span class="s">&#34;The %q field was wrong:\n&#34;</span><span class="p">,</span> <span class="nx">violation</span><span class="p">.</span><span class="nf">GetField</span><span class="p">())</span>
            <span class="nx">fmt</span><span class="p">.</span><span class="nf">Printf</span><span class="p">(</span><span class="s">&#34;\t%s\n&#34;</span><span class="p">,</span> <span class="nx">violation</span><span class="p">.</span><span class="nf">GetDescription</span><span class="p">())</span>
        <span class="p">}</span>
    <span class="p">}</span>
<span class="p">}</span>
</code></pre></div><h3 id="note-about-using-gogo-protobuf-with-status">Note about using GoGo Protobuf with status<a href="#note-about-using-gogo-protobuf-with-status" class="anchor" aria-hidden="true"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M15 7h3a5 5 0 0 1 5 5 5 5 0 0 1-5 5h-3m-6 0H6a5 5 0 0 1-5-5 5 5 0 0 1 5-5h3"></path><line x1="8" y1="12" x2="16" y2="12"></line></svg></a></h3>
<h4 id="update">UPDATE<a href="#update" class="anchor" aria-hidden="true"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M15 7h3a5 5 0 0 1 5 5 5 5 0 0 1-5 5h-3m-6 0H6a5 5 0 0 1-5-5 5 5 0 0 1 5-5h3"></path><line x1="8" y1="12" x2="16" y2="12"></line></svg></a></h4>
<p>TL:DR; <code>gogo/googleapis</code> types work with <code>grpc/status</code>.</p>
<p>While investigating <a href="https://github.com/gogo/grpc-example/issues/9">another issue</a>
relating to <code>gogo/protobuf</code> and the <code>grpc-gateway</code>, github user
<a href="https://github.com/glerchundi">@glerchundi</a>
<a href="https://github.com/grpc-ecosystem/grpc-gateway/pull/529#issuecomment-376822766">pointed out</a>
that <code>gogo/protobuf</code> types could potentially circumvent issues with
<code>golang/protobuf/ptypes</code> referring to its own registry by implementing
<code>XXX_MessageName() string</code> on its types. This turned out to fix all compatibility
issues with <code>grpc/status</code>, so <code>gogo/protobuf</code> was quickly updated
to support this function in <code>gogo/protobuf/types</code> and <code>gogo/googleapis</code>.
As a result of this, <code>gogo/googleapis</code> types now work transparently with <code>grpc/status</code>.</p>
<p><a href="https://github.com/gogo/status"><code>gogo/status</code></a> is still necessary if you want to
use types that only register with <code>gogo/protobuf</code> and don&rsquo;t make use of either
the <code>goproto_registration</code> or <code>messagename</code> GoGo Protobuf extensions.</p>
<p>I&rsquo;ve preserved the old advice here, but it no longer applies. The
<a href="https://github.com/gogo/grpc-example"><code>gogo/grpc-example</code> repo</a> has been updated
to make use of <code>grpc/status</code> again.</p>
<blockquote>
<p>I mentioned above that the <code>status</code> package uses the <code>Any</code> protobuf
message type under the hood. This, combined with the <code>Status.WithDetails</code>
and <code>Status.Details</code> methods <a href="https://github.com/grpc/grpc-go/blob/738eb6b62fe9a30ddfe19934b0a22b1a66fbb661/status/status.go#L162">using the <code>golang/protobuf/ptypes</code></a>
directly causes it to be generally
<a href="https://github.com/grpc/grpc-go/issues/1885">incompatible with <code>gogo/protobuf</code> messages</a>.
One workaround for this is to register your error metadata messages with
<code>golang/protobuf</code> through the <a href="https://github.com/gogo/protobuf/blob/master/extensions.md#goprotobuf-compatibility"><code>goproto_registration</code> extension</a>.
This will work for your own types, but what if you don&rsquo;t have control
over the extensions used? What if you want to use types from
<code>gogo/googleapis</code> as I suggested in <a href="https://jbrandhorst.com/post/gogoproto">my post on <code>gogo/protobuf</code> compatibility</a>?</p>
</blockquote>
<blockquote>
<p>To help with this issue, <a href="https://github.com/grpc/grpc-go/pull/1927">I submitted a PR</a>
to the Go gRPC project to allow the creation of <code>status.Status</code> types from
arbitrary error types that implement a specific interface. This, in combination
with the new <a href="https://github.com/gogo/status"><code>gogo/status</code> package</a> allows
the user the same simple <code>status</code> interface that works with arbitrary
<code>gogo/protobuf</code> registered message types.</p>
</blockquote>
<blockquote>
<p>For an example of this in use, please check out the
<a href="https://github.com/gogo/grpc-example"><code>gogo/grpc-example</code> repo</a>,
which was created to showcase this and other solutions when using <code>gogo/protobuf</code>,
especially together with the gRPC-Gateway. Please ensure you use gRPC Go
<a href="https://github.com/grpc/grpc-go/releases/tag/v1.11.0">v1.11.0</a>
or greater to make use of the <code>gogo/status</code> package.</p>
</blockquote>
<h3 id="further-reading">Further reading<a href="#further-reading" class="anchor" aria-hidden="true"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><path d="M15 7h3a5 5 0 0 1 5 5 5 5 0 0 1-5 5h-3m-6 0H6a5 5 0 0 1-5-5 5 5 0 0 1 5-5h3"></path><line x1="8" y1="12" x2="16" y2="12"></line></svg></a></h3>
<p>The <a href="https://cloud.google.com/apis/design">Google API Design Guide</a>
has <a href="https://cloud.google.com/apis/design/errors">a section on errors</a>
with a thorough discussion of the Status Protobuf type which I encourage you to
read if you want to learn more about general protobuf API error handling.</p>
<p>If you enjoyed this blog post, have any questions or input, don&rsquo;t hesitate to
contact me on <a href="https://twitter.com/JohanBrandhorst">@johanbrandhorst</a> or
under <code>jbrandhorst</code> on the Gophers Slack. I&rsquo;d love to hear your thoughts!</p>

		</div>
	</main>

	<footer id="site-footer" class="section-inner thin animated fadeIn faster">
		<p>&copy; 2021 <a href="https://jbrandhorst.com">Johan Brandhorst</a> &#183; Thanks to Netlify for hosting my blog &#183; <a href="https://jbrandhorst.com/posts/index.xml" target="_blank" title="rss"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" class="feather feather-rss"><path d="M4 11a9 9 0 0 1 9 9"></path><path d="M4 4a16 16 0 0 1 16 16"></path><circle cx="5" cy="19" r="1"></circle></svg></a>
		</p>
	</footer>



	<script src="https://jbrandhorst.com/js/bundle.min.7d8545daa55d62427355498dd8da13f98ff79a7938ce7d2a5e2ae1ec0de3beb8.js" integrity="sha256-fYVF2qVdYkJzVUmN2NoT+Y/3mnk4zn0qXirh7A3jvrg=" crossorigin="anonymous"></script>
	
<script type="application/javascript">
var doNotTrack = false;
if (!doNotTrack) {
	window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
	ga('create', 'UA-96154465-1', 'auto');
	
	ga('send', 'pageview');
}
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>


</body>

</html>
